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第一章  Origin基础知识 
Origin 是美国 Microcal 公司出的数据分析和绘图软件,现在的最高版本为

7.0 http://www.originlab.com/ 

特点：使用简单，采用直观的、图形化的、面向对象的窗口菜单和工具栏操

作，全面支持鼠标右键、支持拖方式绘图等。 

两大类功能：数据分析和绘图。数据分析包括数据的排序、调整、计算、统

计、频谱变换、曲线拟合等各种完善的数学分析功能。准备好数据后，进行数据

分析时,只需选择所要分析的数据,然后再选择响应的菜单命令就可.Origin 的绘

图是基于模板的,Origin 本身提供了几十种二维和三维绘图模板而且允许用户自

己定制模板.绘图时,只要选择所需要的模版就行。用户可以自定义数学函数、图

形样式和绘图模板；可以和各种数据库软件、办公软件、图像处理软件等方便的

连接；可以用 C 等高级语言编写数据分析程序，还可以用内置的 Lab Talk 语言

编程等。 

一、工作环境 

1.1工作环境综述 

 

类似 Office 的多文档界面，主要包括以下几个部分： 

1、菜单栏 顶部 一般可以实现大部分功能 

2、工具栏 菜单栏 下面 一般最常用的功能都可以通过此实现 

3、绘图区 中部 所有工作表、绘图子窗口等都在此 

4、项目管理器 下部 类似资源管理器，可以方便切换各个窗口等 

5、状态栏 底部 标出当前的工作内容以及鼠标指到某些菜单按钮时的说明

 

工作表                矩阵                      绘图 
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1.2 菜单栏 

菜单简要说明： 

File 文件功能操作 打开文件、输入输出数据图形等 

Edit 编辑功能操作 包括数据和图像的编辑等，比如复制粘贴清除等，特别注意

undo 功能 

View 视图功能操作 控制屏幕显示, 

Plot 绘图功能操作 主要提供 5 类功能: 

1、几种样式的二维绘图功能，包括直线、描点、直线加符号、特殊线／符

号、条形图、柱形图、特殊条形图／柱形图和饼图 

2、三维绘图 

3、气泡／彩色映射图、统计图和图形版面布局 

4、特种绘图，包括面积图、极坐标图和向量 

5、模板：把选中的工作表数据到如绘图模板 

Column 列功能操作 比如设置列的属性，增加删除列等 

Graph 图形功能操作 主要功能包括增加误差栏、函数图、缩放坐标轴、交换 X、
Y 轴等 

Data 数据功能操作  

Analysis 分析功能操作 

对工作表窗口：提取工作表数据；行列统计；排序；数字信号处理（快速傅

里叶变换 FFT、相关 Corelate、卷积 Convolute、解卷 Deconvolute）；统计

功能（T－检验）、方差分析（ANOAV）、多元回归（Multiple Regression）；

非线性曲线拟合等 

对绘图窗口：数学运算；平滑滤波；图形变换；FFT；线性多项式、非线性

曲线等各种拟合方法 

Plot3D 三维绘图功能操作 根据矩阵绘制各种三维条状图、表面图、等高线

等 
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Matrix 矩阵功能操作 对矩阵的操作，包括矩阵属性、维数和数值设置，矩阵转

置和取反，矩阵扩展和收缩，矩阵平滑和积分等 

Tools 工具功能操作 

对工作表窗口：选项控制；工作表脚本；线性、多项式和 S 曲线拟合 

对绘图窗口：选项控制；层控制；提取峰值；基线和平滑；线性、多项式和

S 曲线拟合 

Format 格式功能操作  

对工作表窗口：菜单格式控制、工作表显示控制，栅格捕捉、调色板等 

对绘图窗口：菜单格式控制；图形页面、图层和线条样式控制，栅格捕捉，

坐标轴样式控制和调色板等 

Window 窗口功能操作 控制窗口显示 

Help 帮助 

二、基本操作 

作图的一般需要一个项目 Project 来完成，File→New 

保存项目的缺省后缀为：OPJ 

自动备份功能：Tools→Option→Open／Close 选项卡→“Backup Project 
Before Saving” 

添加项目：File→Append 

刷新子窗口：如果修改了工作表或者绘图子窗口的内容，一般会自动刷新，如果

没有请 Window→Refresh 

第二章 简单二维图 

2-1 输入数据 

一般来说数据按照 X Y 坐标存为两列，假设文件为 sindata.dat,如下格式： 



X   sin(x) 
0.0  0.000 
0.1  0.100 
0.2  0.199 
0.3  0.296 
………… 

输入数据请对准 data1 表格点右键调出如下窗口，然后选择 Inport ASCII 找到

sindata.dat 文件打开就行 

 

2-2、绘制简单二维图 

按住鼠标左键拖动选定这两列数据,用下图最下面一排按钮就可以绘制简单

的图形。 

 

 

 

2-3 设置列属性 

双击 A 列或者点右键选则 Properties,这里可以设置一些列的属性。 
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2-4、数据浏览 

Data Display 动态显示所选数据点或屏幕点的 XY 坐标值 

Data Selector 选择一段数据曲线，作出标志 一是鼠标，二是利用

Ctrl,Ctrl+Shift 与左右箭头的组合 

Data Reader 读取数据曲线上的选定点的 XY 值 

Screen Reader 读取绘图窗口内选定点的 XY 值 

Enlarger 局部放大曲线 

Zoom 缩放 

注意利用方向键，以及与 Ctrl 和 Shift 的组合 

2-5、定制图形 

2‐5‐1 定制数据曲线 

用鼠标双击图线掉出下面窗口。 
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2‐5‐2 定制坐标轴: 

双击坐标轴得到,下图 

 

2‐5‐3 添加文本说明 

用左侧按钮 ，如果想移动位置，可以用鼠标拖动。注意利用 Symbol Map

可以方便的添加特殊字符。做法:在文本编辑状态下,点右键,然后选择:Symbol 
Map。 

10 

 



 

2‐5‐4 添加日期和时间标记 

Graph 工具栏上的  

 

2‐5‐5 利用左侧的菜单 

利用左侧的菜单可以作出很多特殊要求的图像，比如两点线段图  

三点线段图等，水平（垂直）阶梯图、样条曲线图、垂线图等 

下面给出一个演示，具体的自己捉摸 
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第三章 数据管理 

3-1 导入数据文件 

前面第二章以说，主要利用 Import 输入文件中的数据，也支持直接数据粘

贴等。 
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3-2 变换数列 

在前面的基础上，增加一列 cos(x)，这不需要另算数据而利用 Origin 本身

就可以做到。 

在数据表上点右键选择 Add New Column 

 

对准 A（Y)列点右键选择 Set Column Values,并设置下面输入框中 
cos(col(x))，点击 OK 得到 
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双击 A 列或者点右键选则 Properties,这里可以设置一些列的属性,下面的左图 

 

并做 cos(x)图,如上面的右图 

3-3 数据排序 

Origin 可以做到单列、多列甚至整个工作表数据排序，命令为“sort …” 

最为复杂的是整个工作表排序，选定整个工作表的方法是鼠标移到工作表左上角

的空白方格的右下角变为斜向下的箭头时单击。具体的自己捉摸吧。 

3-4 频率记数 
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Frequency Count 统计一个

数列或其中一段中数据出现的

频率  

做法对准某一列或者选定的一

段点右键 Frequency Count 

BinCtr 数据区间的中心值 

Count 落入该区间的数据个

数，即频率计数值 

BinEnd 数据区间右边界值 

Sum 频率计数值的累计和 

3-5 规格化数据 

选择某一列，右键→Normalize 
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3-6 选择数据范围作图 

如果想跳到某一行可以用 View→Go To Raw（这里如果发现你设定的行

之前的都没了，这仅仅是没显示出来而不失删除了，想要看到的话：Edit→
ResetToFullRange） 

找到你想要的开始行，点右键→SetAsBegin，同理设定结束行，然后作图。 

3-7 屏蔽曲线中的数据点 

Mask 工具栏默认不显示,可以从 View→Toolbars 设置出来。这样可以用设

置屏蔽区间或者点的颜色等 

3-8 曲线拟合 

即用各种曲线拟合数据，在 Analysis 菜单里，常用的有线性拟合，多项式

拟合等，还可以利用 Analysis→Non-Linear Curve Fit 里的两个选项做一些特

殊的拟和。 

默认为整条曲线拟合，但可以设置为部分拟和，和 mask 配合使用会得到

很好的效果。 



第四章 绘制多层图形 
图层是 Origin 中的一个很重要的概念，一个绘图窗口中可以有多个图层，

从而可以方便的创建和管理多个曲线或图形对象。 

4-1 打开项目文件 

例子为\Tutorial\Tutorial_3.opj 

 

4-2 Origin 的多层图形模板 

Origin 自带了几个多图层膜板.这些模板允许你能够在取得数据以后,只需单

击"2D Graphs Extended"工具栏上相应的命令按钮,就可以在一个绘图窗口把

数据绘制为多层图。 

在项目\Tutorial\Tutorial_3.opj 中四哥绘图窗口即为四个图形模板。它们

分别为双 Y 轴（DoubleYAxis）、水平双屏（Horizontal2Panel）、垂直双屏

（Vertical2Panel）和四屏（4Panel）图形模板。 
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双 Y 轴图形模板  

http://micro.ustc.edu.cn/Origin/images/4.htm35.jpg


如果数据中有两个因变量数列，它们的自变量数列数列相同，那个可以使用

此模板。   

水平双屏图形模板 

如果数据中包含两组相关数列，但是两组之间没有公用的数列，那么使用水

平双屏形模板。 

 

垂直双屏图形模板图 

水平双屏图形模板的前提类似，只不过是两图的排列不同 
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四屏图形模板  

如果数据中包含四组相关数列，而且它们之间没有公用的数列，么使用四屏图形

模板。 

 

上述四种膜板再加上九屏图形模板就是 Origin 所提供的自带多图形模板。 

4-3 在工作表中指定多个 X 列 
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对准 D 点右键选择 SetAs X 设为 X 列得到 

 

说明:默认 Y 与左侧最近的 X 轴关联,也就是 BC 与 A，EF 与 D 关联。 

 

4-4 创建多层图形 
20 

 



Origun 允许用户自己定制图形模板。如果你已经创建了一个绘图窗口，并

将它存为膜板，以后就可以直接基于此模板绘图，而不必每次都一步步创建并定

制同样的绘图窗口。 

4‐4‐1 创建双层图 

步骤: 

 (1) 激活“Layers”的工作表窗口。 

 (2)单击“sinx”列的标题栏，使其高亮，表示该列被选中。 

 (3) 作出单层图 

 (4) 在激活 Layer 窗口的前题下，Tools－》Layer，如下图，这个工具包含两

类： 

Add 图层和 Arrange 图层 

 

双击图层 2 做成右上图那样，然后 OK 
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4‐4‐2 关联坐标轴 

Origin 可以在各图层之间的坐标轴建立关联，如果改变某一图层的坐标轴比

例，那么其它图层的也相应改变。 

做法双击：Layer 上的 2 图标，在调出的 Layer 对话框中点 Layer 
Properties，然后选择 Link Axes Scales。 

 

 

4-5 存为模板 

File→Save Template As，以后就可以用此模板。 
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第五章 非线性拟合 
拟合曲线的目的为要根据已知数据照出响应函数的系数。 

5-1 使用菜单命令拟合 

首先激活绘图窗口，选择菜单命令 Analysis，则可以看到 
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名称 含义 拟合模型函数 

Fit Linear 
 线性拟

合 
y=A+B*x 

Fit 
Polynomial 

多项式

拟合 
y=A+B1*x+B2*x^2 

Fit  Expone
ntial Decay 

指数衰

减拟合  

Fit  Expone
ntial 
Growth 

指数增

长拟合  

Fit 
Sigmoidal 

S 拟合 ，

Boltzmann 

Fit Gaussion 
Gaussi
on 拟合 

Fit 
Lorentzian 

Lorentzi
an 拟
合 

Fit 
Multipeaks 

多峰值

拟合 
按照峰值分段拟和，每一

段采用 Gaussion 或者



24 

 

Lorentzian 方法 

Nonlinear 
Curve Fit 

非线性

曲线拟

合 

内部提供了相当丰富的拟

合函数，还支持用户定制 

5-2 使用拟合工具拟合 

为了给用户提供更大的拟合控制空间，Origin 提供了三种拟合工具，即线性

拟合工具、多项式拟合工具、S 拟和工具。具体自己去体会。 

5-3 非线性最小平方拟合 NLSF 

这是 Origin 提供的功能最强大、使用也最复杂的拟合工具。方法是 Analysis
→Non-Linear Curve Fit→Advanced Fitting Tools 或者 Fitting Wizad 

具体的请自己体会。 



 

高级模式 利用 Function→new 可以自定义拟合函数 

基本模式 利用 new 可以自定义拟合函数 
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Wizad 模式 

高级模式中利用 Action→Dataset 设置，在基本模式中用 Select Dataset 设
置。 
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第六章 数据分析 
数据分析主要包含下面几个功能： 

简单数学运算（Simple Math） 

统计（Statistics） 

快速傅里叶变换（FFT） 

平滑和滤波（Smoothing and Filtering） 

基线和峰值分析(Baseline and Peak Analysis) 

6-1 简单数学运算 

数据来自 Tutorial\Tutorial_1.dat,它的背景是对同一物理量进行三次测量

得到的结果。为清楚起见我们舍弃三个误差数列，并只绘制中间数据段的曲线。 

 

6‐1‐1 算术运算 

这是实现 Y=Y1(+-*/)Y2 的运算，其中 Y 和 Y1 为数列，Y2 为数列或者数字。 

命令为：Analysis→Simple Math 
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6‐1‐2 减去参考直线 

s－→Subtrart:Straight Line 

此时光标自动变为

激活曲线 Test3，Analysi

,然后在窗口上双击左键定起始点，然后再在终止点双击，

6‐1‐3 垂直和水平移动 

沿 Y 轴垂直移动。步骤如下： 

激活数据曲线 Test3  

选择 est3，Analysis→Translate：Vertical 这时光标自动变为

此时会 Test3 曲线变为原来的减为这条直线后的曲线。 

垂直移动指选定的数据曲线

  

双击曲线 Test3 上的一个数据点，将其设为起点。  

这是光标形状变为 ,双击屏幕上任意点将其设为终点。  

这时 Origin 将自动计算起点和重点纵坐标的差值，工作表内 Test3 列的值也自

水平移动和此类似。 

6‐1‐4 多条曲线平均 

前激活的数据曲线的每一个 X 坐标处，计算当前激活

的图

这个不知道那里出了问题，我的没测试成功，新曲线没有出现。 

动更新为原 Test3 数列的值加上该差值，同时曲线 Test3 也更新。 

多条曲线平均是指在当

层内所有数据曲线的 Y 值的平均值。Analysisi→Average Multiple Curves 
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6‐1‐5 插值 

插值是指在当前激活的数据曲线的数据点之间利用某种方法估计信的数据点。 

Analysis→Interpolate and Extrapolate 

 

6‐1‐6 微分 

也就是求当前曲线的导数,命令为: Analysis→Calculus:Differentiate 

6-1-7 积分 

用梯形法进行积分,命令为:Analysis→
Calculus:Integrate 

6-2 统计 

）、标准误

性、多

归分析（Linear、Polynomial and Multiple Regression 
Analysis） 

6-3 快速傅里叶变换 

号分解成不同频率的正弦函数的叠加，在信号是最重要的最基本

的工具之一。 

一般包括 FFT 及定制频谱图，采样率，相关、卷积和去卷积 

对当前激活的数据曲线

包括：平均值（Mean）、标准差（Standard Deviation，Std，SD
差(Standard Error of the Mean)、最小值（Minimum）、最大值

（Maximum）、百分位数（Percentiles）、直方图（Histogram）、T 检验（T-test 
for One or Two Populations）、方差分析（One-way ANOVA）、线

项式和多元回

傅里叶分析把信
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6-4 平滑和滤波 

包括用 Savitzky-Golay 滤波器平滑，用相邻平均法平滑，用 FFT 滤波器平滑，

数字滤波器，如低通、高通、带通、带阻和门限滤波器。 

6-5 基线和峰值分析 

具体存在哪些方法，不多说，仅仅说一下 Origin 提供用来读取图形窗口上的数

据和坐标的几个工具，它们为: 

屏幕读取工具 
数据读取工具 
数据选择工具 

利用这些工具可以精确的读取数据等。 
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第七章 绘制三维图形 
 

Origin 支持三种数据类型的三维绘图功能：XYY 工作表数据、XYZ 工作表数

据、矩阵数据，但是三维表面图只能由矩阵数据创建。 

下面以做一个最简单的正方体为例子说明。 

7-1 把工作表转为矩阵 

7‐1‐1 导入数据 

创建一个三维数据文

件，内容为 XYZ，类似：

 x y z 
1 1 10 
1 2 10 
1 3 10 
1 4 10 
1 5 10 
………  

并把最后一列 z(Y)设置

为 z(z)。 

  

  

  

  

     

7‐1‐2 类型转换 

Origin 有几种转换方法，这需要取决于工作表数据，对于此有规律的数据，

选择 Regular XYZ 就行，得到 Matrix5 工作表(对例子来说为 100X100 矩阵)。 
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7-2 创建三维表面图和等高线图 

激活矩阵窗口,选择 Plot3D 中的相应命令,就可以会出想要的图。 

菜单命令 含义 模板文件 

3D Color Fill Surface 三维彩色填充表面图 MESH.OTP 

3D X Constant with 
Base 

三维 X 恒定、有基底表面

图 
XCONST.OTP 

3D Y Constant with 
Base 

三维 Y 恒定、有基底表面

图 
YCONST.OTP 

3D Color Map Surface 三维彩色映射表面图 CMAP.OTP 

3D Bars 三维条形表面图 3DBARS.OTP 

32 

 



3D Wire Frame 三维线框架面图 WIREFRM.OTP 

3D Wire Surface 三维线条表面图 WIREFACE.OTP 

Contour-Color Fill 彩色填充等高线图 CONTOUR.OTP 

Contour-B/W 
Lines+Labels 

黑白线条、具有数字标记

的等高线图 
CONTLINE.OTP 

Gray Scale Map 灰度映射等高线图 CONTOUR.OTP 

因为数据太规律化,没法显示出各个命令的真正区别,特别是等高线的,一点也看

不出来,希望大家自己慢慢捉摸。 

7-3 定制三维图形 

激活图形窗口后,在 Format->Plot 里设置图形的各个参数,随着图形的不同,
这个选项也不同。 

当激活 3D 图形窗口后,会出现控制图形透射的控制按钮 

 

3D 绘图功能非常强大,选项也多得很,希望大家在用到的时候仔细捉摸一下,
把你的图做得清楚好看。 
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第八章 创建版面页 
版面页(Layout)用于创建图形外观,项目中的任何绘图窗口和工作表窗口

的图片都页面中显示和排序.另外也可以向版面页中加入图形目标和文本，以加

强外观的表现效果。 

利用 File→new→Layout 或者工具栏上的 新建版面页。 

添加的方法为在 Layout 上点右键→ADD……或者从 Layout 菜单执行。 

下面在 Layout1 中把 Graph1 和 shidata 放进来了，并添加了文本说明。 

 

第九章  Origin中 Excel的使用 
Origin 可以和 Excel 结合使用,方法看看就会,不多说了。 

第十章 数据的输入输出 

10-1 数据导入导出 

导入数据用 Import 命令，注意调开窗口中的 Option 这个选项，这里可设

置倒入数据的很多选项。 
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数据导出:Export ASCII,会调出选项对话框，可以设置以何种方式分割数据列。 
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10-2 图形和版面的导出 

激活绘图窗口,Edit→Copy Page 就可以复制图像。 

而 File→Export Page 可以把图像存为图像文件。  

10-3 在其它应用程序中使用 Origin 

在装有 Origin 的机子上，Word 中可以直接插入 Origin 图像，并可以直接

在 Word 中通过双击这个图形来调用 Origin 来编辑图片。 

插入方法：插入→对象→Origin Graph，这将新建一个空白的 Origin 图形。 
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或者利用插入－》从文件创建，把以前做好的 Origin 文件插入进来。 

 

下面为在 Word 中直接编辑 Origin 文件的窗口。 
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附录：有关 ORIGIN使用中常见的问题 

一、数据的输入 

1、 直接输入 

打开 ORIGIN 默认的是出现一个包含 2 个数据列的名为 DATA1 的

WORKSHEET 表格，第一列为 X，第二列为 Y。可输入一组 X、Y 实验数据。 

如果是同一 X 值下有多个对应的 Y 值，可按工具栏上的添加列按钮，根据

需要添加相应的数据列； 

如果是想把不同的数据画在同一个坐标系中，如将 X、Y；X1、Y1；X2、
Y2；X3、Y3 对应的数据都画到同一个坐标系中，可以在现有的两列数据列后再

添加 6 个数据列，分别将第三列、第五列第七列设为 X 列，然后将数据列全部

选中，点击相应的曲线类型产生相应的曲线。 

2、输入有规律的数据 

曲线生成后，双击曲线，可打开对话框，从中修改曲线相应的属性，如曲线

的颜色、线型、连接方式、数据点符号形状、大小、颜色等。 

双击坐标轴，可在打开的对话框中设置坐标轴的属性，如坐标轴的起点与终

点值，标记条间隔、样式，是否显示坐标轴等。 

双击坐标轴标签，可以编辑坐标轴标题，其中有上下标、希腊字符等。 

双击图例标签，可以编辑对应的曲线标记。 

双击左上角的坐标系按钮（或叫层按钮，ORIGIN 中，把一个坐标系称为一

个层 LAYER），可打开坐标系属性按钮。对坐标系中的数据曲线进行添加、去

除等操作。 

双击图形窗口中的空白处，可打开页面属性设置对话框，对页面的大小、颜

色等进行设置。 

2、 从文件输入数据 

ORIGIN7.0 可输入各种格式的数据，在输入之前，必须有一个空的数据表格，

即 WORKSHEET，从文件菜单中选择输入（IMPORT），然后在出现的子菜单

中选择相应的数据文件格式。7.0 支持红外 SPC 格式文件，可以直接输入并作图； 
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保存为文本文件的数据也可直接输入。 

也可以从 EXCEL 表格中输入数据。 

① 多组数据共存与一个坐标系及数据处理时曲线的选择的问题 

② 多 Y 轴坐标系问题及数据作图 

③ 特殊坐标系（T 型坐标系） 

④ 曲线平滑问题（用插值法解决不均匀 X 值） 

⑤ 面积积分问题（利用区域选择工具可限定积分区域） 

⑥ 数据预处理问题 

⑦ 利用脚本窗口解决特殊要求问题（LABTALK 编程） 

⑧ 描图问题 

二、画曲线上某点的切线 

时常有人问起，如何画曲线上某点的切线，这里给出一个 ORIGN 网站提供

的插件 Tangent Lines，下载附件，解压得到一个.opk 文件，打开 ORIGIN，将该

文件拖入 ORIGIN 窗口内即可自行安装，生成两个按钮，用那个数据读取按钮选

择你所画曲线上的某一数据点，双击鼠标则生成 一条过该点的切线。 

三、如何在一个图中设置上下两个具有某种关系的 X 轴？ 

如下图 



 

步骤： 

Double-click on the bottom X axis to open the X Axis dialog. On the Title & Format 
tab, select the Top Selection and then check the "Show Axis & Ticks" checkbox. 
Repeat these steps on the Tick Labels tab. Your graph should now display both the 
top and bottom X axes with tick labels. (You can also do this with script: 
layer.x.showaxes=3; layer.x.showLabels=3; )。 

To display X2 as 1240/X, run the following script, from the Script Window, opened 
by selecting Window:Script Window: 

layer.x2.label.formula$ = "1240/x" 

This then places labels on the top X axis, at same positions corresponding to labels in 
bottom X axis, and these new labels are values that are computed using the specified 
formula. 

NOTE 1: You may have to double-click on the Top X axis tick labels to open the 
Axes dialog. On the Tick Labels tab, check the 'Set Decimal Places' checkbox, and 
enter in 2 (or some number) for the number of decimal places. 

NOTE 2: The formula can be any string that is a function of x, which is calculable 
using LabTalk. 

NOTE 3: Similar to the top X axis in this example, you can turn on right Y axis and 
set labels of that too. But note that the command should be:  
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layer.y2.label.formula$ = "x+10"; 

where you still use "x" in the formula even though you are setting the Y axis labels.  

四、调换数据列的前后顺序 

从视图菜单中的工具中选择列工具栏，可打开列操作工具按钮，从而方便地

调整数据列的前后顺序。 

五、如何将不同条件下得到的许多组 XY 以 3D 的方式表达出来？ 

可以用瀑布图，也可以用其它的 3D 软件画成 3D 图，如下面的数据图： 

 

画成 3D 的形式则如下所示： 
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六、如何使复制的 ORIGIN 图形只包括坐标和曲线？ 

作好的 ORIGIN 数据图经常要复制到 E|WORD 文档中，利用编辑菜单中的

复制页面命令，得到的图有较大的空白区，在 WORD 中需用图片工具中的裁剪

工具进行调整。每次都这样处理十分不便。可以在 ORIGIN 中作如下设置来达到

不留空白区的效果。 

按 CTL+u，在 page 中设置“Clip Boeder Width”为 1 或 0，可以观察一下效

果。 

  

七、如何平移坐标系里的曲线？ 

在菜单 analysis--translate 下面有 2 个，一个是水平移动的，一个是垂直移动

的。 

方法是 先选择移动的方法，这个时候鼠标变为一个方框形状，然后在曲线

上面选择一个点，回车（enter 键），这个是移动的开始点；再选择第 2 个点，

这个是移动的终止点，回车（enter 键）。这样就从第一个点移动到第 2 个点了。 

当需要精确地移动曲线时，最简单的是将 X 轴都加上一个固定值，曲线右移，

都减一个值，曲线左移，当然上下移动对 Y 值作类似处理即可。 

八、如何去除相同的重复数据？ 
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如何在 origin 中去除一列中雷同的数据，由于记录的频率很快，因此有很多

数据相同。 

 

九、如何给坐标刻度加单位？ 

双击轴或 Y 轴，在打开的对话框上方选择“Tick labels”，在右侧稍下一点有

添加前缀“prefi”和后缀“suffi”，在“suffi”对应的框里输入%，则 Y 轴标签数字后

有%出现，当然你也可以添加其它单位，举一反三，你也就知道加前缀的效果了。 

 

十、图形放大方式 

    数据的放大有 3 种方式： 
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第一种就是用左边工具栏中的放大器，可产生局部放大的曲线； 

第二种是先按下 CTRL 键，再用放大器在曲线上拖出一个矩形，这时会产生

一个新的窗口显示矩形框中部分的曲线，在原始曲线中移动矩形，新窗口中的曲

线随之变化； 

第三种是从 TOOLBARS 中调出 2D 图形扩展工具，在数据窗口下，选中要

画的数据，点击工具栏上的那个上下分布的坐标按钮，这时在生成的图形窗口中

出现上下两个图形，上面的是原始数据曲线，下面的是局部放大曲线，移动上面

曲线中的矩形可改变放大区间。 

十一、怎样在字符上面加一横线表示无量纲变量？ 

 在文本属性中：\ab(text),其中 text 为所要加横线的字符。 

十二、如何用 origin 7.0 将两个峰叠加？ 

 

    将这两组数据输入到两个数据表格中，用其中一个作图后，在分析菜单中选

择 subtract，从子菜单中选择 FROM 参考数据（第一项），在打开的对话框中左

边列出了可用的数据，选择 DATA*_B 作为 Y1，DATA*_D 作为 Y2，操作符选

择+，按确定键即可，注意此时原来的 B 列被新的加和数据所代替，图中生成的

新曲线为加和后的曲线，如果想看三条曲线在一起的效果，可以用原始数据的第

二组作图，然后将加和后的数据添加到该图中即可。  

十三、能否做一个多元的二次回归？ 
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按多元拟合的要求，将 Y 值输入到第一列，x 值输入到其它各列中，从列菜

单的设置列值命令中将每个 X 列的值求平方，选中三个 X 列，从统计菜单中选

择多元回归命令，一切 OK。 

十四、在 ORIGIN 中能否画一个 4D 的图形？ 

在 ORIGIN 中如果有 4 列数据，可用前 3 列画一个 3DXYZ 散点图，将第 4
列定义为颜色，用不同的颜色代表第 4 列的值的大小。 

具体做法是画好 3D 散点图后，从格式菜单中选择“PLOT”，打开 PLOT 
DETAIL 对话框，将符号颜色设置为 COLOR MAPPING，并选择第 4 列为颜色

值。 

十五、如何快速找到拟合曲线中任一 X 值对应的 Y 值？ 

对于 Linear, Sigmoidal, and Polynomial Fit tools 本身带有查找 X 值和 Y 值的

功能。 

对于非线性拟合器，可从 ACTION 菜单中选择 RESULTS 查找。 

You can also find XY unknowns by using the INTERPOL.OTW worksheet. To 
open this worksheet, select the Open Template button on the Standard Toolbar and 
choose Worksheet Template (.OTW) for Files of Type. Then, select the Buttons 
folder and choose INTERPOL.OTW. Once the worksheet has opened, place your X 
and Y data in the first two columns. Finally, enter a value (or set of values) in the 
NewX (or NewY) column and click on the "Find new Y values" (or "Find new X 
values") button. 

十六、如何调整坐标轴的位置？ 

双击 X 轴打开对话框，在 TITLE AND FORMAT 中选择设置轴位置，从中

选择 AT POSITION 一项，在下面的文本框中输入 Y 轴的值，X 轴即挪到指定的

Y 轴处，同理，对 Y 轴作同样处理可将 Y 轴移到摾定的 X 轴位置处。 



 

十七、如何作曲线指定点上的切线（一条或多条）？ 

利用 ORIGIN 提供的免费插件，可方便地作任何一点的切线，若要作多条切

线应当将第一条切线的数据另到一个新的数据表格中，因为该插件在生成新切线

时会将原来的数据覆盖掉。 

 

十八、如何画一个 f(x,y)=0 函数据的图像？ 

利用 FxyPlot.opj 模板可画此种图。打开该模板，可以看到下面的提示。 

This script, FxyPlot plots an implicit function: f(x,y)=0  

by scanning the given xy domain to determine the points on curve within the tolerance. 
Because of this method, it will take time to draw with high resolution, and it may 
present specious points and/or connections.  
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To execute, enter the following command in the script window:  

  run.section(fxyplot,main) 

从 Windows 菜单中打开 script window，将 run.section(fxyplot,main)复制到窗

口中并按下回车键。出现函数定义对话框，在其中定义好函数后，按“OK”，进

入 X，Y 范围定义对话框。定义完毕，按“OK”，程序开始运行，生成相应的数

据表格和图形。 

十九、如果定义如下图的坐标标签？ 

 

双击X轴，在打开的对话框中选择Custom Tick Lables进行设置。在Special 
Ticks 中选择 Specai 中的 Manual Label，进行如下图的设置。 
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若要隐藏某些标签，可进行如下图的设置。 

 

二十、如何批量将每列的数据乘以同一个数？ 

由于时常碰到要进行单位转换，每列的数据需要同时乘以同一个系数，若只

有几列，则手动采用 col(a)=col(a)*A 的形式解决，若列数太多，则容易出错，用

什么脚本可以实现这一目的？ 

for(i=1; i<=n; i++) 

{ 

    col($(i)) = col($(i)) * C; 

} 

编辑后，要全选中代码，然后按回车 

二十一、如何在 Origin 画 3D 图

Origin 的 3D 图基本上都是从 Matrix 上画的（3D Scatter 从 Worksheet 画），

这让很多初学者费解，因为这里涉及到 Worksheet to Matrix 的转换，而转换的

各种方法让人摸不到头脑。如果用过 Surfer 绘制 3D 图，就能感觉到当原始的 
XYZ 数据点是不规则的时候，要产生规则的网格去绘制 3D 图将肯定涉及到插

值。插值的好坏直接影响到图上很多细节的表达。这里先不介绍各种插值 
(gridding) 的细节，只区别数据是否规则，画个粗略的 3D 图。 
 
当数据转换成 Matrix 的时候，Matrix 的 Cell 上只显示 Z 值，XY 值在 
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Column 和 Row 的 Header 上，默认情况下显示的是 Index，若要看到 XY 
值，菜单上选 View : Show XY。 

001.jpg (48.09 KB)  
   

 

直接转换 -- Direct Convert (Edit : Convert to Matrix : Direct)

直接转换 Worksheet 数据成 Matrix，各个 Cell 一一对应。当 wroksheet 中不

包含 Matrix 的 XY 信息时，转换后的 Matrix 的 XY 值为 index： 

002.jpg (53.19 KB)  
  直接转换 -- Worksheet 中含有 Matrix 的 XY 值

这里假设 worksheet 数据的组织结构与 Matrix 一样 (X 按列排)，并且 X 值
存在第一行，Y 值存在第一列。注意，对于这样直接转换，X Y 的值必须时均

匀间隔的。 
 
若 X 值按行排，则选择 Y varies acros columns，转成的 Matrix 会转置 (这里

有点晕哦  :-)) 

004.jpg (57.15 KB)  
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XYZ 数据转换成 Matrix -- Regular

如果是 XYZ 这样的数据，则应该先考察一下数据是怎样分布的，Highlight XY 
column，画 Scatter，若是规则的数据，则选择 Edit : Comvert to Matrix : 
Regular 来转换。 

005.jpg (49.24 KB)  

   

 

XYZ 数据转换成 Matrix -- Sparse

若为稀疏矩阵，则用 Sparse 转换。稀疏矩阵也是 Regular 的，只不过存在 
Missing Value。 
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006.jpg (45.31 KB)  

   

XYZ 数据转换成 Matrix -- Random

若数据是非规则的，则应该用 Random 转换。Random 转换涉及插值，有好几

种算法，一般推荐 Renka Cline，具体算法先不累述。 

007.jpg (78.92 KB)  

   

Matrix Done

以上是数据准备阶段。当有了 Matrix 后，则可以绘制 3D 图，包括 Contour 
了。 
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下面用已经做好的 Matrix (借用 Matlab 的 Sample) 绘制 3D color map 
surface。其他的 3D 图操作基本类似。 

Plot

将文件拖入 Origin，选择 Plot : 3D Color Map Surface。得到图如下： 

 

附件 

2007-9-1 01:42 

008.jpg (23.23 KB)  
   

 

 

Custom

正如一些网友所说，这个图确实不好看，很粗糙。这是因为： 
1、数据点达到一定程度时会自动打开 Speed Mode。Speed Mode 只采用了部分

数据绘图。这点也许有人会觉得没有必要，这是因为数据量太少。Origin 对导

入的数据大小没有限制，数据大小的限制只跟系统资源相关，因此当导入的数据

是几十甚至几百万个点时（别不相信，有这样的数据），每次动一下都要刷新一

次的话，那将是个更恼人的问题。 
2、默认情况下 color map 只分成 8 个 Level。理由同上。 
要做出精美的图，用户可以自己调节。首先调一下 Color Map。双击图打开 
Plot Details。在 Matrix 的 Color Map 标签点 Level，将其 Level 设成 64 或 
128。 
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附件 

2007-9-1 01:43 

009.jpg (68.52 KB)  
   

 

 

Custom

这时候图更难看了？因为原来的图是有 grid line 和 Contour line 的，Level 划
分多了 Line 自然也多起来，把原来的颜色覆盖了。在 Grids 标签除去 Grid 
line： 

 

附件 

2007-9-1 01:44 

53 

 

http://www.simwe.com/forum/member.php?action=credits&view=getattach
http://www.simwe.com/forum/attachment.php?aid=135638&nothumb=yes
http://www.simwe.com/forum/misc.php?action=viewratings&tid=795709&pid=1120448


010.jpg (27.25 KB)  

   

Custom

Surface/Projection 标签除去 Contour Line 

 

附件 

2007-9-1 01:44 

011.jpg (18.14 KB)  

   

 

Custom
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最后，在 Layer 的 Size/Speed 标签除去 Speed Mode 

 

附件 

2007-9-1 01:45 

012.jpg (26.28 KB)  
   

 

 

Done

这样图片就好看多了。注意的是当数据很大时，不用 Speed Mode 又对图进行操

作的话，会因为刷新问题而等待较长时间。 
至于颜色，由于个人美术水平不高，大家可以自己调一下。 

013.jpg (28.05 KB)  
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origin高级使用技巧

1.怎么求非自然数为底的幂函数 

Origin中的自然数的幂函数很容易，用EXP函数就可以了，但是其它幂函数没有，

例如：将一列数据转变为以 10 为底，数列为幂指数，用 10^col(A)就可以了。 

2.如何输入σ，±这样的符号 

添加文本，然后点击Ctrl+M，选择你所需的字符，插入就行了。 

3.自定义公式拟和技巧 

origin7.0 中虽然提供了强大的拟合曲线库外，但在实际使用中，你可能会发觉在

所提供的曲线库中没有你想要拟合的公式。这时你就可以使用用户自定义公式进

行拟合。过程如下：  

（1）打开主工具栏中analysis的non-linear curve fit....,这时会出来一个选择公式界

面。  

（2）选择编辑公式，需要你提供公式名称以供系统保存；还要提供参数的个数

及主变量及因变量符号。  

（3）按你需要的公式写在编辑框内，注意千万别写错了。写完后按save进行保

存。  

（4）现在开始拟合：在action中选dataset，提供主变量和因变量的一些相关参数。 
 

（5）在action中选simulate，在参数中填上你根据数据及其它一些条件确定的粗

略的初始参数以及拟合起始点的位置及拟合点数，然后按下create curve就会在图

上出现一条拟合曲线，但这往往与期望值差距较大，因此接下来需要进行参数优

化。  

（6）参数优化采用试错法，根据曲线形状逐渐改变参数，注意，多参数时改变

任何一个参数都会改变曲线形状，因此可以一次变一个参数，直到达到满意的形

状。  

（7）在action中选fit，按下Chi-sqr和 10-lit。  

（8）在action中选results，按下param worksheet生成拟合曲线及数据。此时可以

关闭拟合界面。  
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（9）在图左上角右键点 1，选add/remove plot，将多余的曲线删除，将nlsf系列

曲线留下。拟合数据可在param worksheet中看到。  

这样就完成了一次自定义曲线拟合。 

4.如何将三个纵坐标放在一个图中 

加两个图层的方法设置三个纵坐标，在想要移动的y坐标轴上点右键打开坐标轴

对话框，然后选title&format---axis下拉框选at position=然后在下面的框里输入想

要移动多远就可以了 

5.怎样画直线穿越Y轴的图 

（1）先把你的图线画出来，这时你的图中纵轴自然在最左边 

（2）点击纵轴，水平拖动其到x=0 的位置，这样则图线不变化，仅仅是纵轴移

动到了坐标的原点。 

对于横轴，也可以将其上下拖动到需要的位置，如坐标原点。 

另外，用鼠标拖动的时候，如果不好控制水平，或者竖直方向 

也可 先点中对象（坐标轴等），然后 按住 SHIFT键不放，点 键盘上的 上下

或者左右方向键，即可较好的控制 移动的距离。 

或者： 

（1）双击纵轴,打开坐标轴操作窗口 

（2）点击打开TITLE&FORMAT 

（3）在AXIS下拉选项中选择AT POSITION= 

（4）在其下栏中输入数据即可  

6.Origin中中文间距不一的问题 

升级到 7.5 版本，问题解决 

7.怎样把“行”的数据画到X或Y轴上？ 

选定一行数据，复制之后，在Origin中，在一列中选定一些格（不是选定一列，

必须等于或大于原始数据的量，否则数据便少），然后粘贴就行了。 

附：内置函数 

abs : 绝对值  

acos : x 的反余弦  

angle(x,y) : 点(0,0)和点(x,y)的连线与 x 轴之间的夹角  
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asin : x 的反正弦  

atan : x 的反正切  

J0 : 零次贝塞耳函数  

J1 : 一次贝塞耳函数  

Jn(x,n) : n 次贝塞耳函数  

beta(z,w): z > 0, w > 0 β函数  

cos:   x的余弦  

cosh : 双曲余弦  

erf : 正规误差积分  

exp : 指数  

ftable(x,m,n) : 自由度为 m,n 的 F 分布  

gammaln : γ 函数的自然对数  

incbeta(x,a,b) : 不完全的β函数  

incf(x,m,n): m,n自由度上限为 x 的不完全 F 分布  

incgamma(x,a) : 不完全 γ 函数  

int : 被截的整数  

inverf : 反误差函数  

invf(x,m,n) : m 和 n自由度的反 F 分布  

invprob : 正态分布的反概率密度函数  

invt(x,n) : 自由度 n 的反 t 分布  

ln : x 的自然对数  

log : 10 为底的 x 对数  

mod(x,y) : 当整数 x 被整数 y 除时余数  

nint : 到 x 最近的整数  

prec(x,p) : x 到 p 的显著性  

prob : 正态分布的概率密度  

qcd2 : 质量控制 D2 因子  

qcd3 : 质量控制 D3 因子  

qcd4 : 质量控制 D4 因子  
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rmod(x,y) : 实数x除以实数y的余数  

round(x,p) : x 环绕 p 的准确度  

sin : x 的正弦  

sinh : x 的双曲正弦  

sqrt : x 的平方根  

tan : x 的正切  

tanh : x 的双曲正切  

ttable(x,n) : 自由度为 n 的学生氏t分布  

y0 : 第二类型零次贝塞耳函数  

y1 : 第二类型一次贝塞耳函数  

yn(x,n) : 第二类型 n 次贝塞耳函数 
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